Solución al problema de los terminales virtuales en negro con el driver propietario de Nvidia

Desde siempre, utilizando el controlodor propietario de Nvidia, me quedaba con las terminales virtuales (VTs, la que se activa con Ctrl-Alt-F1) ciegas, es decir, funcionaban pero no veía nada, sólo un fondo negro.

Ya me había acostumbrado, o resignado más bien, y últimamente hasta optaba por Nouveau a pesar de su bajo rendimiento. Pero al instalar Wheezy con KDE, el tema por defecto incluía efectos que ralentizaban mucho el escritorio. Así que volví a probar el controlador propietario de Nvidia para volver a quedarme sin ver nada en las terminales virtuales.

Así que volví a dar una vuelta por los caminos de Google y encontré un par de pistas. La primera sugería añdir el parámetro de Kernel vga=normal actualizando la configuración de GRUB2. Esta opción no funcionó, pero investigando los diferentes valores que podría tener dicho parámetro dí con esta tabla de modos VESA. Tras modificar /etc/default/grub para pasar el parámetro vga=791 y ejecutar update-grub (ambas cosas como root, claro) conseguí mantener las terminales virtuales junto con el driver propietario NVIDIA.

/etc/default/grub:

Desde siempre, utilizando el controlodor propietario de Nvidia, me quedaba con las terminales virtuales (VTs, la que se activa con Ctrl-Alt-F1) ciegas, es decir, funcionaban pero no veía nada, sólo un fondo negro.

Ya me había acostumbrado, o resignado más bien, y últimamente hasta optaba por Nouveau a pesar de su bajo rendimiento. Pero al instalar Wheezy con KDE, el tema por defecto incluía efectos que ralentizaban mucho el escritorio. Así que volví a probar el controlador propietario de Nvidia para volver a quedarme sin ver nada en las terminales virtuales.

Así que volví a dar una vuelta por los caminos de Google y encontré un par de pistas. La primera sugería añdir el parámetro de Kernel vga=normal actualizando la configuración de GRUB2. Esta opción no funcionó, pero investigando los diferentes valores que podría tener dicho parámetro dí con esta tabla de modos VESA. Tras modificar /etc/default/grub para pasar el parámetro vga=791 y ejecutar update-grub (ambas cosas como root, claro) conseguí mantener las terminales virtuales junto con el driver propietario NVIDIA.

/etc/default/grub:

Desde siempre, utilizando el controlodor propietario de Nvidia, me quedaba con las terminales virtuales (VTs, la que se activa con Ctrl-Alt-F1) ciegas, es decir, funcionaban pero no veía nada, sólo un fondo negro.

Ya me había acostumbrado, o resignado más bien, y últimamente hasta optaba por Nouveau a pesar de su bajo rendimiento. Pero al instalar Wheezy con KDE, el tema por defecto incluía efectos que ralentizaban mucho el escritorio. Así que volví a probar el controlador propietario de Nvidia para volver a quedarme sin ver nada en las terminales virtuales.

Así que volví a dar una vuelta por los caminos de Google y encontré un par de pistas. La primera sugería añdir el parámetro de Kernel vga=normal actualizando la configuración de GRUB2. Esta opción no funcionó, pero investigando los diferentes valores que podría tener dicho parámetro dí con esta tabla de modos VESA. Tras modificar /etc/default/grub para pasar el parámetro vga=791 y ejecutar update-grub (ambas cosas como root, claro) conseguí mantener las terminales virtuales junto con el driver propietario NVIDIA.

/etc/default/grub:

 

Desde siempre, utilizando el controlodor propietario de Nvidia, me quedaba con las terminales virtuales (VTs, la que se activa con Ctrl-Alt-F1) ciegas, es decir, funcionaban pero no veía nada, sólo un fondo negro.

Ya me había acostumbrado, o resignado más bien, y últimamente hasta optaba por Nouveau a pesar de su bajo rendimiento. Pero al instalar Wheezy con KDE, el tema por defecto incluía efectos que ralentizaban mucho el escritorio. Así que volví a probar el controlador propietario de Nvidia para volver a quedarme sin ver nada en las terminales virtuales.

Así que volví a dar una vuelta por los caminos de Google y encontré un par de pistas. La primera sugería añdir el parámetro de Kernel vga=normal actualizando la configuración de GRUB2. Esta opción no funcionó, pero investigando los diferentes valores que podría tener dicho parámetro dí con esta tabla de modos VESA. Tras modificar /etc/default/grub para pasar el parámetro vga=791 y ejecutar update-grub (ambas cosas como root, claro) conseguí mantener las terminales virtuales junto con el driver propietario NVIDIA.

/etc/default/grub:

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.